Author Topic: php  (Read 160 times)

cnnx

  • Confirmed Member
  • **
  • Posts: 2
  • Karma: +0/-0
php
« on: August 14, 2020, 06:16:00 PM »
I want to install this dating software but the docs say it needs php 5.4, im running ubuntu 18 how do I install php 5.4? also isnt there security flaws/risks by using outdated php versions?

thanks

maverick

  • Administrator
  • Veteran Member
  • *****
  • Posts: 3169
  • Karma: +212/-7
    • Maverick Webworks
Re: php
« Reply #1 on: August 15, 2020, 12:24:04 AM »
I've personally never used Ubuntu so I don't much about it. You need to seek assistance from a Ubuntu source on how to configure and manage a Ubuntu server. You can try by possibly starting here https://askubuntu.com/questions/1052746/can-i-install-php-5-3-5-on-ubuntu-server-18-04-lts

Quote
also isnt there security flaws/risks by using outdated php versions?
IMO there's always security issues to some degree with all PHP versions, maybe a bit more with outdated versions, but not really any critical vulnerabilities. It mostly comes down to what extra security software your server is running to help prevent any serious exploits.

Etano has had fewer vulnerabilities reported than most any open source software available, only one vulnerability was ever brought to our attention which was addressed back in version 2.3 .... https://www.cvedetails.com/product/23140/Datemill-Etano.html?vendor_id=10117

Compare that with Wordpress as an example ... https://www.cvedetails.com/vulnerability-list/vendor_id-2337/product_id-4096/


DO NOT PM me asking for personal help. Post your problem or request in the forums so the entire community can contribute and benefit.

cnnx

  • Confirmed Member
  • **
  • Posts: 2
  • Karma: +0/-0
Re: php
« Reply #2 on: August 15, 2020, 04:44:04 AM »
Okay, what are you guys using if not ubuntu? debian? centos? other? I just want to try this software to see if it suits my needs.


maverick

  • Administrator
  • Veteran Member
  • *****
  • Posts: 3169
  • Karma: +212/-7
    • Maverick Webworks
Re: php
« Reply #3 on: August 15, 2020, 11:41:12 AM »
WAMP has always been among the most popular for setting up a development and testing server environment on the Windows operating system.

WampServer - https://sourceforge.net/projects/wampserver/ ... https://www.wampserver.com/en/


I used WAMP for many years but switched to Uniform Server Zero XIII several years ago because it's a light weight solution that uses less resources and is easier to setup and configure. It's also portable, meaning it can even be run from a USB stick on any PC. Requires no installation or registry changes to your PC.

Uniform Server Zero XIII - https://www.uniformserver.com

http://www.uniformserver.com/ZeroXII_documentation/php_version_switching.html

http://www.uniformserver.com/ZeroXII_documentation/plugins_detail.html

If your running a MAC or LINUX computer there's also XAMPP, but it's more complicated to work with and more resource intense as well.
https://www.apachefriends.org/index.html

DO NOT PM me asking for personal help. Post your problem or request in the forums so the entire community can contribute and benefit.

nootkan

  • Confirmed Member
  • **
  • Posts: 3
  • Karma: +0/-0
Re: php
« Reply #4 on: September 03, 2020, 03:07:22 PM »
Hello all, I am currently looking at this dating script to see how it compares to ph7 which I have up and running on a wamp local server on my computer.  Based on my research on the Etano website and this forum it looks very promising. 

I am a little confused as to whether your script will work with newer versions of php like 5.6, 7.0, 7.2 etc. 

I see in the documents that 5.3-5.5 is listed and would like some clarification before I start the install. 

My current wamp install includes: apache 2.4.33, php 5.6.35, mysql 5.7.21

maverick

  • Administrator
  • Veteran Member
  • *****
  • Posts: 3169
  • Karma: +212/-7
    • Maverick Webworks
Re: php
« Reply #5 on: September 03, 2020, 07:14:56 PM »
You must use PHP version 5.2, 5.4 or 5.5
DO NOT PM me asking for personal help. Post your problem or request in the forums so the entire community can contribute and benefit.

nootkan

  • Confirmed Member
  • **
  • Posts: 3
  • Karma: +0/-0
Re: php
« Reply #6 on: September 05, 2020, 01:42:04 PM »
Thanks Maverick, I went a head and tried to install and discovered what you just told me.  Too bad, was hoping to try a new open source dating script.  Are there plans to upgrade the script to the newer versions of php in the future? Thanks for your time.

maverick

  • Administrator
  • Veteran Member
  • *****
  • Posts: 3169
  • Karma: +212/-7
    • Maverick Webworks
Re: php
« Reply #7 on: September 05, 2020, 06:49:28 PM »
The script was being developed and upgraded to support newer versions of php and was supposedly near completion and ready for release, but we have not heard from the developer for months now, so at this point we're uncertain of it's future.

http://forum.datemill.com/index.php?topic=5075.0

DO NOT PM me asking for personal help. Post your problem or request in the forums so the entire community can contribute and benefit.

nootkan

  • Confirmed Member
  • **
  • Posts: 3
  • Karma: +0/-0
Re: php
« Reply #8 on: September 06, 2020, 12:09:36 AM »
Maverick, thanks for the update.

Doesn't sound good hope the developer is just troubleshooting and not in poor health. 

With everything that is going on in 2020 we should all be patient and keep him in our thoughts. 

I am going to set up wamp on another computer with php 5.5 and play around while I wait. 

Fingers crossed.