Author Topic: Mailer Issues  (Read 205 times)

onlineservices

  • Veteran Member
  • *****
  • Posts: 270
  • Karma: +0/-0
Mailer Issues
« on: July 21, 2020, 03:31:47 AM »
After several tries and after searching this forum for solutions I got tired to solve this issue. That is ADMIN not receiving notification mails. But when a user register they are getting activation mail and user side notification mails properly. Only Admin notification is in trouble.

ISSUE - When a user registers or cancels membership, admin use to get notification. Right from last year we are not getting this notification mails. Because we changed the hosting. Then we found it has mariadb instead of Mysql. All the functions was ok except this notification mailing. So to get this notification mails, again we changed the hosting to MYSQL and Php.5.6.

TROUBLESHOOTING:

1. Server - Mysql and Php 5.6 - ok
2. CronJob - Runs every 2 min externally as hosting provider privilage is 15 min once.
3. Etano Admin Panel Error Log - Nothing found
4. Etano Admin panel - General setting - Futures and options - Admin mail and notification mails are same with own domain extension and found correct

GUESS:
1. We think some of our files which sends the mail may be corrupted or it may be with errors.
2. Or should we make any settings in PHP configuration and settings. The mailing related parameters are provided here.

In PHP Extension Plugins

Mailparse is disabled.


In PHP Options

Disabled - session.cookie_secure
Enabled - short_open_tag
Disabled - log_errors
Disabled - session.use_strict_mode
Enabled - allow_url_fopen
Disabled - session.cookie_httponly
Disabled - zlib.output_compression
Enabled - file_uploads
Disabled - display_errors
Enabled - expose_php


mail.force_extra_parameters = Its blank Nothing here

Additional parameters for the mail() function used to send mail. For example, to use your custom Sendmail configuration: -C /dir/conf.cf

disable_functions = system, exec, shell_exec, passthru, mysql_list_dbs, ini_alter, dl, symlink, link, chgrp, leak, popen, apache_child_terminate, virtual, mb_send_mail

This directive allows you to disable certain functions for security reasons. It takes on a comma-delimited list of function names. Only internal functions can be disabled using this directive. User-defined functions are unaffected.

The above is the status of my current PHP section.

So kindly suggest me how to solve the NOTIFICATION email receipt.

Thank You in Advance.

maverick

  • Administrator
  • Veteran Member
  • *****
  • Posts: 3169
  • Karma: +212/-7
    • Maverick Webworks
Re: Mailer Issues
« Reply #1 on: July 21, 2020, 01:15:58 PM »
You say you changed hosts.

Where you enter your email address for ... "Send alerts to this email address"

Did you remember to also create this email address on your new host account?

Make sure to use an email address that's specific to your domain.
DO NOT PM me asking for personal help. Post your problem or request in the forums so the entire community can contribute and benefit.

onlineservices

  • Veteran Member
  • *****
  • Posts: 270
  • Karma: +0/-0
Re: Mailer Issues
« Reply #2 on: July 21, 2020, 07:21:37 PM »
Yes its already there and even we are getting several mails to it.

maverick

  • Administrator
  • Veteran Member
  • *****
  • Posts: 3169
  • Karma: +212/-7
    • Maverick Webworks
Re: Mailer Issues
« Reply #3 on: July 22, 2020, 01:19:59 AM »
You had this issue once before, maybe try looking into what you did previously to resolve the issue:

http://forum.datemill.com/index.php?topic=4319.msg19314#msg19314


Also check your email account to see if the notifications are arriving there, if they are but your not receiving them in your email client then the issue could be with the configurations in your email client.
DO NOT PM me asking for personal help. Post your problem or request in the forums so the entire community can contribute and benefit.

onlineservices

  • Veteran Member
  • *****
  • Posts: 270
  • Karma: +0/-0
Re: Mailer Issues
« Reply #4 on: August 04, 2020, 11:19:33 PM »
I tried all these things. But not working out.

Can you help to identify the below issue.

In one of our etano site we found 744 mails in que at `dsb_queue_email`.  But these are old. Can I delete.

Like to know what may be the reason as its not sending from que. All settings in Admin for mailing is perfect. Cron Job Ok and got checked cron reports.

Thank You

maverick

  • Administrator
  • Veteran Member
  • *****
  • Posts: 3169
  • Karma: +212/-7
    • Maverick Webworks
Re: Mailer Issues
« Reply #5 on: August 05, 2020, 06:23:27 AM »
Maybe try this solution to see if it then sends the alerts.

http://forum.datemill.com/index.php?topic=4753.msg21550#msg21550


Yes you should delete all the old emails in the `dsb_queue_email.

The problem could also be caused if using php 5.6, it's been posted many times that 5.6 isn't recommended for Etano and may cause issues to occur.
DO NOT PM me asking for personal help. Post your problem or request in the forums so the entire community can contribute and benefit.