Author Topic: New Skin Not Displaying Correctly? 3 Possible Solutions To Try  (Read 873 times)

KHDev

  • Global Moderator
  • Veteran Member
  • *****
  • Posts: 505
  • Karma: +43/-2
  • Etano Contributor (Skins & Mods)
    • KH Web Development
The most common issue that pops up for me is that when users install a new skin it can sometimes look "Broken". The reason for this in most cases is that there is old styling still cached (stored) locally in your browser or on your server.

Heres 3 possible solutions

1) Clear your browsers history/cache.

You can usually find your history in your browsers settings menu.

(If you're unsure how to then visit http://refreshyourcache.com/en/cache/)



2) Regenerate your skin

In your admin panel under 'skin settings' use the 'regenerate' to refresh the skin.



3) Edit Cache rule in .htaccess file

If you access your root folder (where the main etano files) find the .htaccess file and edit it. (Note depending on how your viewing your files the .htaccess file might be hidden so you'll need to set your file manger to show hidden files which varies per hosting company)


Code: [Select]

###### FIND THIS SECTION ###########

<FilesMatch "\.(xml|txt|css|js)$">
Header set Cache-Control "max-age=172800, proxy-revalidate"
</FilesMatch>


and change max-age=172800 to max-age=0 save it and try reloading your site (Remember to clear your browsers history and cache just in case)

If the issue is fixed then return to the .htaccess file and change the max-age back to the original setting max-age=172800



In most cases the 3 solutions above will resolve the issue.

If your issue is still there then try contacting your host to see if they can refresh your website cache. If all 4 options fail to fix it then try contacting the developer of the skin to make sure its not a design error.


Hope this helps :)