Author Topic: htaccess error  (Read 3055 times)

haveachat2001

  • Guest
htaccess error
« on: December 16, 2007, 05:34:19 PM »
Hi there
           i cannot seem to run the site with the htaccess file on the site
all it gives me is  sever configuration error ?? even if there is nothing in the file
so at the moment i simply deleted the file and all works well
any ideas on why this would be

Johnboy

  • Global Moderator
  • Veteran Member
  • *****
  • Posts: 566
  • Karma: +40/-2
Re: htaccess error
« Reply #1 on: December 16, 2007, 08:19:12 PM »
Note: At this point, depending on your configuration, you might receive an error: **500 Internal Server Error**
In this case please edit the .htaccess file and remove all lines starting with php_value or php_flag.
These lines set the best environment for Etano but it can run even if you remove these lines.

You can find this info and more handy stuff at
http://www.datemill.com/etano/wiki/   ;)
I LOVE these forums!!! So helpful...

haveachat2001

  • Guest
Re: htaccess error
« Reply #2 on: December 16, 2007, 11:05:40 PM »
Thanks Johnboy
                      but i think its a little more than just the php settings some how
as even if the htacceess file is empty its still causes the error  :(
and as the site is now live i dont want to create tooooo many errors :grin:
and im on PHP 4 not 5 but was thinking of upgrading,  not sure yet, as if its not broken then don't fix it  :grin:

haveachat2001

  • Guest
Re: htaccess error
« Reply #3 on: December 17, 2007, 12:23:57 AM »
The problems is the server
           For servers with PhpSuExec installed, having config lines in your .htaccess file to configure PHP doesn't work any longer.

You should remove the lines that begin with "php_value" and "php_flag", these will need to be moved to a new file that we're going to create, called:
php.ini
In php.ini, there is a different format to define your PHP settings. All lines are in the following format:
setting_name = setting_value

So, this means if you move the settings from .htaccess to php.ini, you must convert the format. Let's say you have the following line in your .htaccess file:
php_value register_globals 0

the corresponding php.ini format is as follows:
register_globals = Off

Notice how the value 0 becomes Off (without quotes) and 1 becomes On. Now if your php_value has quotes like the following, for example:
php_value include_path ".:/home/user/lib"

The corresponding php.ini format is:
include_path = ".:/home/user/lib"

Once you have converted your .htaccess file to a php.ini, please upload it to your server into public_html.
Then, add the following line into the .htaccess file in your public_html:
suPHP_ConfigPath /home/username/public_html

Where "username" is your cPanel user name.

admin2

  • Guest
Re: htaccess error
« Reply #4 on: December 17, 2007, 09:56:44 AM »
Excellent info haveachat.
A default php.ini will be added with the next patch but since the script cannot detect if .htaccess is accepted or not, this is good info anyway.

haveachat2001

  • Guest
Re: htaccess error
« Reply #5 on: December 20, 2007, 04:55:40 AM »
Ty Admin
              :D  and here is another tit bit for you

suExec causes php scripts to execute under the owner's id instead of apache's id , which is due to obvious security advantage. However it also enforces a tighter restriction on implemented permissions. So previously, where you probably were able to implement 777 as an easy method of getting things up and running, now suExec will block execution (and give the internal server error) when it finds a file/folder with group having write permissions (hence the need to scale these back from 777 to 755).

 :-X :( :o :x
if its not one thing its another

admin2

  • Guest
Re: htaccess error
« Reply #6 on: December 20, 2007, 05:05:39 AM »
With suexec, the Etano installer would detect that it is able to write files directly and would setup the script to use the direct disk mode instead of ftp thus there would be no need for 777 in tmp or anywhere else.
But it would be a good addition to the installer to require 777 on tmp only for ftp op mode.